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PREFACE 

This book serves as an open educational resource for both undergraduate and postgraduate degree programs, offering a detailed, step-by-step guide to 

modeling future land use change using the MOLUSCE plugin in QGIS. Designed to bridge the gap between theoretical knowledge and practical application, 

this guide is meticulously crafted to meet the needs of students, educators, and practitioners alike. 

Within the book, readers will find comprehensive instructions on utilizing advanced algorithms such as Artificial Neural Networks (ANN), Logistic Regression 

(LR), and Weight of Evidence (WoE) to analyze and predict future land use changes. The guide provides detailed processes for ingesting raster data 

representing historical land use patterns and pertinent explanatory variables, training predictive models, and simulating future land use scenarios.  

The book not only enhances learning in academic settings by providing real-world applications and case studies but also equips industry professionals with the 

skills necessary to conduct advanced spatial analysis and contribute meaningful insights in their fields. By understanding and managing land use dynamics, 

users can anticipate and plan for changes, facilitating informed decision-making in areas such as urban planning, natural resource management, and 

environmental conservation. 

Whether you are a student aiming to master land use modeling and geographic information systems, a teacher looking for robust educational tools, or a 

practitioner in need of refining your technical expertise, this book offers invaluable guidance and support. It ensures that users at all levels gain proficiency in 

leveraging modern technologies to explore and solve geographic challenges effectively, empowering proactive planning and management of land resources for 

resilient and sustainable landscapes. 
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CHAPTER 1: INTRODUCTION 

1.1 Modeling the Future Land Use Change using MOLUSCE 

MOLUSCE (Modules for Land Use Change Simulations) is a powerful plugin designed to analyze and predict future land use changes within specific regions. 

Utilizing advanced algorithms such as Artificial Neural Networks (ANN), Logistic Regression (LR), and Weight of Evidence (WoE), MOLUSCE integrates various 

spatial and non-spatial factors to simulate land use dynamics over time. By ingesting raster data representing historical land use patterns and pertinent 

explanatory variables, MOLUSCE trains predictive models to forecast future land use scenarios.  

This modeling approach offers several benefits for understanding and managing land use change. Firstly, MOLUSCE provides valuable insights into the potential 

impacts of various socio-economic, environmental, and policy factors on land use dynamics. By simulating future scenarios, allows stakeholders to anticipate 

and plan for changes in land use patterns, facilitating informed decision-making in areas such as urban planning, natural resource management, and 

environmental conservation. Additionally, MOLUSCE enables the assessment of different land management strategies and policy interventions, helping to 

identify optimal pathways for sustainable land use development.  

MOLUSCE empowers users to explore and visualize future land use changes, enabling proactive planning and management of land resources for resilient and 

sustainable landscapes. 
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1.2 Required Equipment/s, Software/s, and Inputs 

Equipment/s Software/s Inputs 

       

• A computer with sufficient processing power 

and memory is necessary to run QGIS and 

MOLUSCE efficiently, especially when dealing 

with large datasets or complex analyses. 

• There are no strict formal system requirements. 

• It is recommended to have a computer with 

modern specifications to ensure smooth 

performance. 

 

• QGIS 3.0 or later can be used for data preparation 

works 
     

• Users require raster data representing historical 

land use patterns and explanatory variables 

(such as socio-economic factors, and 

environmental variables) relevant to the study 

area. 

• These raster datasets can be obtained from 

various sources, including remote sensing data, 

governmental agencies, or research institutions. 

• In the absence of such raster data sets, it is 

necessary to prepare those raster data sets 

through QGIS software, using the data as 

needed. 

         

• This version of QGIS needs to be installed to use 

the MOLUSCE plugin.  

• Users can download and install the plugin from the 

QGIS Plugin Repository here. 

QGIS Platform Overview 

• Type: Open-source 

• Installation: Available for Windows, macOS, Linux 

Table 1 -Required Items for Study 

QGIS Desktop 3.22.7 

 

QGIS Desktop 2.18.15 

 

Computer 

 

Raster Data 
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1.3 Final Result of the Modeling 

 

Our modeling process using MOLUSCE has provided a clear picture of what 

Dambulla's landscape could look like in 2035. We used data from 2005 and 

2020 to predict how land use will change in the future. By looking at various 

spatial and non-spatial factors such as environmentally sensitive areas, land use 

efficiency of the area, accessibility, access to basic services, and population 

density, we have made some strategic assumptions about how the land in the 

Dambulla region will be used in the coming years.  

The results show us where things might stay the same and where big changes 

could happen. This helps us understand how our cities might grow, how 

agricultural activities might change, and how we can protect our environment 

better. By knowing what could happen, we can make better plans for the future, 

ensuring our landscapes are healthy and sustainable for years to come. 

Figure 1 -Final Result of the Modeling 
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1.4 Data Preparation and Modeling Process 

Figure 2 -The Modeling Process. 
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CHAPTER 2: DATA PREPARATION 

Example Study Area  

 

 

Data Collection 

  

For this exercise, the Dambulla Regional area has been selected as the example 

study area. This is one of the major cities according to the National Physical 

Plan for 2050. Greater Dambulla Regional Boundary was introduced under this 

National Physical Plan of Sri Lanka, and it is to be used in this exercise. 

 

By conducting a field visit in the Dambulla area, we identified its special 

characteristics. One of the special things that we focused on while doing the 

study was how the future land use pattern could be. Accordingly, we studied a 

considerable amount of past land use patterns and current land use patterns in 

this area. After collecting a certain amount of data with the help of local 

residents, we engaged in further studies with the help of local-level institutions 

and officials. 

Additionally, we obtained some pre-processed datasets from government 

agencies such as the Urban Development Authority, Sri Lanka Mahaweli 

Authority, and the National Building Research Organization. 

Figure 3  -The Study Area 
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2.1 Preparation of the Land Use Layers 

To model the future land use change of a particular area using MOLUSCE, it is necessary to select a period and prepare relevant land use raster layers. These 

land use layers must be classified under certain major land uses. A high count of land use categories may cause errors while using MOLUSCE. In this exercise, 

the period considered here is from 2005 to 2020, to predict the future land use change, and we used the classified land use layers for the years 2005 and 2020 

separately. Both the layers should have the same land use categories. However, there is a practical possibility that one or more land use categories that 

did not exist in 2005 will be added by 2020. 

In this situation, we cannot see that kind of scenario and the Built-up areas, agricultural lands, vegetation layers, and water bodies are the categories that 

are included in these layers that we have used. 

         
Figure 5 -Land use layer  for the year 2005 Figure 4 - Land use layer  for the year 2020 
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Looking at the preparation of these two layers, the vector layers should be prepared first. Here we were able to obtain two pre-processed vector layers for the 

years 2005 and 2020 through their associated government agencies. If you are trying to make a land use prediction for an area like this, first find out if the area 

has pre-processed land use vector layers. Once you have gotten them, you can present the land use categories as needed through tasks such as updating 

their attribute tables. 

The standard categorization of land uses can be shown as follows. If you are looking to do a detailed land use classification, Level 3 categorization is best for 

that. When it comes to Level 2, land uses are quite compact, and a collection of several land uses mentioned in Level 3 is included here in one category. 

Level 1 Level 2 Level 3 

Build up 
Non-built-up 

 

Business 
Commercial 
Education 
Government (Institutional) 
Health 
Industries/Distribution 
Open Land 
Other 
Residential 
Roads 
Transport 
Wetland 

 

Airport 
Animal Clinics 
Bakery / Spa / Saloon/laundry / Shops and Houses 
Bank 
Bare Land (Land Sale / Non-Use Land / Etc.) 
Borrow Pits 
Bus Depot 
Bus Stands 
Cemetery 
Child Education Centers / Child Day Care Centers 
Church 
Condominium Scheme 
Conference & Exhibition Centers 
Construction Office & Yards 
Construction Site 
Corporations 
Court Houses 
Departments / Boards / Authorities 
Elderly Homes 
Embassy  
Financial Support Institution / Insurance Company 
Fuel Stations 
Garments 
General Hospital (Large Size Hospital) 

Government Quarters 
Health Care Centers 
Hostels & Domes 
Hotel & Motel 
Hotel with More than 100 Rooms 
Housing Scheme More than 10 Houses 
Housing Scheme More than 100 Houses 
Individual Private Houses / Dwelling Houses 
International School / Private School 
Kovil 
Lakes 
Logistics and Distribution Centers 
Low-Income Houses 
Manufacturing Plants 
Market 
Marshy 
Medium Size Hospitals (District/Military Hospitals) 
Metal Quarry 
Military Admin Office 
Ministries 
Mosque 
Motor Vehicle Yard 
Museum 
Library 

Table 2 – Standard Land Use Categorization  

Table 2 -Standard Land Use Categorization 
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Regarding the Dambulla area, we mainly identified 4 land use categories. This can be expressed as a level 2 type of categorization because many types of 

land uses are shown in this one category here. For this categorization of the layer, first, we open the 2020 land use vector layer from the 2005 and 2020 land 

use layers through the QGIS 3.22.7 version. You can use any version of QGIS for this. 

Step 01 –  

1.1 Open the QGIS on your computer and click on “New Empty Project”. 
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1.2 Then the workspace will be shown as follows on your screen. Next, we have to import the relevant vector layer. 
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Step 02– Importing vector layers into QGIS  

1.1. You can open your vector files with QGIS in the following way using the layer toolbar. (Layer > Add Layer > Add Vector Layer)  

Otherwise, you can use the short key (Ctrl+Shift+V) to open the vector files. 
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1.2. Then the following window will appear on the screen. You have to browse the location that the data files stored on your computer.  
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2.3 After clicking on “Browse”, the following window will open. Then, go to the relevant folder and select the vector file. Usually, a shape file consists of 6 other 

files. The file type you should choose to open here is the "AutoCAD Shape Source" file. As per the instructions, click on that layer, and after that click on 

“Open”. 

 

 

1 

2 
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2.4 Again, click on “Add” to add the layer to the workspace.  
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2.5 The land use layer will appear on the screen as follows. 
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Step 03– Setting up the Coordinate Reference System (CRS) 

The Coordinate Reference System of all the layers used for this land use prediction should be the same. The first thing we prepare in this way is the Land Use 
Layers. Here we choose a Coordinate Reference System for this layer, this Coordinate System must be used for all the layers prepared from now on. 

3.1 To set up the Coordinate Reference System, first, right-click on the layer, and click on “Properties”. Then, the layer properties will open. 
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3.2 Under the “Source” tab, the assigned coordinate reference system can be seen. If you want to change CRS, click on the icon near the position that the 

current CSR showing.  
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3.3 Then, the following “Coordinate Reference System Selector” window will open. In this scenario, “EPSG 4326” is the CRS that we want to select. For that, 

type the name in the search bar as follows. Then the CRS will appear under the “Predefined Coordinate Reference Systems”. Simply click on that and click 

“OK” to proceed.  

 

 

1 

2 

3 
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3.4 Now click on “Apply” and “OK” to change the Coordinate Reference System.  
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Step 04 – Functions related to updating the Attribute Table  

4.1 Now, right-click on the layer and click on “Open Attribute Table”.  
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4.2 The Attribute Table of the layer will open as follows. Under the column “Mainuse”, we can see the land use of every plot of the Dambulla regional 

area.  

 

We divide all the above land uses into 4 main categories. They can be shown below. 
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Agricultural Lands Built-up Areas Vegetation Water Bodies 

Agricultural Land 

Chena 

Coconut 

Mixed Crop 

Paddy 

Archeological Sites 

Aviation 

Bank & Allied 

Commercial/ Residential 

Commercial 

Educational 

Health 

Home Garden 

Industrial 

Institutional 

Open Space 

RDA Road 

Other Road 

Railway 

Religious 

Reservation 

Residential 

Socio-cultural 

Sports & Amusement 

Sores & Warehouse 

Tourism 

Transportation 

Under Construction 

Utility 

Vacant Building 

Vacant Land 

Forest 

Grassland 

Marshy 

Plantation 

Other Plantation 

Scrub 

Water Bodies 

Catchment Area 

Dam 

Abandon Tank 

River 

Water Tank 

 

 

 
Table 3 -Land use categorization for the selected land use layers 
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4.3 Next, we update these 4 land use categories in the attribute table above. For that, the following steps should be followed. 

• First, we should create a new field in the attribute table named “2020”.  

• Click on the pencil icon and turn on the “Toggle editing mode”.  
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4.4 Now the layer is in editable mode. Then, click on the icon for “New field” as follows.  
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4.5 After clicking on the “New field” icon, the following window will open. Then, enter the Name as “2020”.  

4.6 Then, you have to select the type of the field. For that, expand the “Type” option here. 
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4.7 We are going to enter a text in this field. Therefore, the type named "Text (string)" should be selected.  
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4.8 Since I am going to type a word here, I will set the text length as “25”. But we can specify the amount we need according to the length of the word or several 

words we use. After setting all these, click on “OK” to proceed. 
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4.9 Now, the newly added field will be shown as follows.  
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4.10 Now, we have to add the values into this new field. For that, we should filter each land use from the attribute table, according to our classification. 

1. Open the “Select by the expression”. Then, the following window will open. 

2. Click on the “>” mark and expand the “Fields and Values”. Or you can double-click on the “Fields and Values” to expand it. 

3. Double-click on “Mainuse”.  

4. Click on “all unique”. All the characters under the “Mainuse” will be shown as follows.  

 

1 

2 

3 

4 
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5. Then, you have to enter the following expression on the expression tab. For that, double-click on “Mainuse”, type “=”, and double-click on the relevant 

land use category according to our classification. 

According to the above steps, first, select the land uses under the category "Agricultural Lands". Once done entering a land use using this [“Mainuse” = 

‘Agricultural Land’], type “or” and follow the same steps to add other land use categories into the expression. The “or” operator is used here to create a logical 

condition that selects features based on multiple criteria. 

• So, add each land use continuously in this way,  

“Mainuse” = ‘Agricultural Land’ or “Mainuse” = ‘Chena’ or “Mainuse” = ‘Coconut’ or “Mainuse” = ‘Mixed Crop’ or “Mainuse” = ‘Paddy’ 

 

5 

6 
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After entering all land use categories into the expression using the above way, click on “Select Features”. 

The selected data will be shown as follows in the blue color.  

 



31 | P a g e  
 

 

4.11 In the next step, we have to add the text for the “2020” column. According to the above steps, we selected here the land use categories for the category 

"Agricultural Lands". For that, click on the icon for “Open field calculator”.  
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4.12 The field calculator will open. Click on the “Update existing field” and make sure to display the “✔” mark on that. Through this, an existing field in the 

attribute table will be updated.  
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4.13 Now, we have to select the existing field that we want to update.  

       

    

After selecting the field, you can use the following expression to add “Agricultural Lands” to the selected field at once. Then the newly added field of all the land 

uses we selected above will be updated as "Agricultural Lands" on the attribute table. 

• Once done entering this expression, you can click on “OK” to proceed. This expression contains,  

Concat (“Name of the existing field”, ‘The value’) 

• You should correctly type this expression using single commas and double commas. If you do not enter this correctly, you will have an error message. 

• For that, click on this expandable tab. • Then select “2020”. 
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If 

you 

want to 

deselect all the selected features, you can use the below tool.  

• The expression, 

Concat (“2020”, ‘Agricultural Lands’) 

 

• Double Quotes (" "): Used for field names to reference 

the data in those fields. 

• Single Quotes (' '): Used for literal strings to include 

fixed text values. 

• Now, the values are added to the attribute table.  

•  

 



35 | P a g e  
 

 

By following the same steps as above, the attribute table should also be updated for the main land use categories that we have selected namely built-up areas, 

vegetation, and water bodies. (As shown in Table 3) Once this "2020" field in the attribute table is completely prepared, it will look like this.  
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4.14 After adding these data successfully, click on the pencil icon again and save the edits.  
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Step 05 - Rasterization of the layers 

When we convert a vector layer to a raster layer in QGIS, the choice of field for rasterization is crucial for accurate representation. The selected field determines 

the values assigned to each raster cell, influencing the interpretation of the resulting raster layer. It's essential to note that string-type fields, containing text or 

categorical labels, cannot be selected for rasterization. This limitation arises because rasterization requires numeric values to represent information in raster 

cells effectively. Numeric attributes, such as integer fields for categorical data and floating-point or double fields for continuous or decimal data, are suitable 

choices for rasterization. 

For categorical data, such as land use categories, an integer field with class codes (e.g., 1 for urban, 2 for forest) is ideal. Conversely, continuous data, like 

elevation, is best represented using a floating-point field with actual elevation values. When converting vector layers with string fields, it's advisable to create 

new numeric fields, perhaps using the Field Calculator tool, to store relevant quantitative information before rasterization. By selecting the appropriate field type, 

we can ensure the meaningful interpretation of the resulting raster layer, facilitating accurate analysis and visualization of spatial data. 

Accordingly, by adding another field in the same attribute table that we prepared, we should give a numeric value for the 4 main land use categories. Let's give 

numerical values for land uses as follows. 

Land Use Category Numeric Value 

Built-up Areas 1 

Agricultural Lands 2 

Vegetation 3 

Water Bodies 4 

                                                           Table 4 -– Numerical values for the land use categories 
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5.1 Turn on the editable mode of the layer by clicking the “Toggle editing mode” tool. Then, add a new field as before. Name it as “LU” and set the type as a 
numeric type. I set here the type “Whole number (integer)” and the length as “10”.  

 

1 2 

3 
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5.2 The newly added field will be shown as follows.  
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5.3 Open the “Select by Expression” and expand the “Fields and Values”. Then, double-click on “2020” and type “=”. After that, click on “All Unique” and 

double-click on a land use category. Then the expression will be entered as follows. Finally, click on “Select Features”.  

 

1 

2 

3 

4 

5 

6 
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5.4 The selected features are displayed in blue color. Now, open the “Field Calculator” and update the existing field “LU”, according to the numerical values 

that we introduced under Table 4. Use the expression as concat (“LU”, ‘1’) for the built-up areas. According to the Table 4, change the numeric value in this 

expression.  

 

1 

2 

3 

4 
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Numeric values are added to this field as follows.  
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5.5 Then, follow the same steps and add values for other land use categories as well. As the final step, save the edits. 
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5.6 After saving the edits, right-click on the layer and open the layer properties.  
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5.7 Go to the “Symbology” properties. Next, click on “Simple Fill”. Then expand the “Stroke style”.  

  

1 

2 

3 
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5.8 Select “No Pen” from the expanded list. After that, click on “Apply” and “OK”.  

  

1 

2 3 
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5.9 Outlines of the vector layer will be removed from this process as follows. 
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5.10 Let’s categorize this vector layer. For that, again open the layer properties and go to the “Symbology” properties tab. Then, click on “Single symbol” and 

expand it. Select “Categorized” from the expanded list.  

   

 

 

5.11 After selecting the "Categorized" option, the controls will be shown 

here like this. Next, expand the option “Value” 

1 
2 

3 
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5.12 Select the field “LU” from this expanded list. After selecting the field, click on “Classify”. 

  



51 | P a g e  
 

5.13 The classification will be displayed as follows. If you want to change the colors of each category, double-click on the color from the classification and select 

the color that you want. Or you can change the color ramp. Then, click on “Apply” and “OK”.  
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Here is the classification according to the main 4 land use categories, that we introduced to the Dambulla region. 
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Rasterization with QGIS 3.22.7 

To convert this vector layer into a raster layer, open the “Rasterize” tool as follows. 

Click on “Raster” in the toolbar > Conversion > Rasterize (Vector to Raster) 
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Then, the Rasterize tool will appear on the screen. Select the layer you want to convert to a raster on the “Input layer”.  

Next, expand the “Field to use for a burn-in value” option and select the numeric field as follows. Here, we are going to rasterize this layer through the field 

"LU". 
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Then, select the “Output raster size units” as “Georeferenced units”.  
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Next, enter the “Width/Horizontal” and “Height/Vertical” resolutions as “30”. Generally, we use the pixel size of a raster layer as 30x30. That's why we entered 

the same size here. But depending on the dataset we are using; we can resample the layer and change the pixel size.  

 



57 | P a g e  
 

Next, we select the output extent. After clicking the icon shown in the corner of that option, we can select the desired layer as below and use the output extent. 

Click on the icon > Calculate from layer > Select the layer 
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The output extent will be set up according to the above-selected layer as follows.  
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Then, browse a location to save this layer. For that, click on the below icon and select “Save to File”.  

  



60 | P a g e  
 

As follows, now you can browse and select a location on your computer to save the layer. Once you select the location and set the File name as below, click 

on “Save” to proceed.  
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Now all the parameters are ready. Click on "Run".  

After this is finished running, a message will appear on the screen as shown in the image below right side.  
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Now the raster layer can be seen as follows. 
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Once the rasterization is finished as above, follow the steps below for ease of identifying their land use categories separately in clear colors. 

• Right-click on the layer to open the layer properties and go to the “Symbology” tab.  
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• Set the “Render type” as “Singleband pseudocolor”.  
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• Set the “Interpolation” as “Linear”. 

• Then you can select any color combination under “Color ramp”.  

 

• Set the "Mode" as “Equal Interval” and set the "Classes" as “4”. (The number of classes may vary on your land use layer’s classification. In this layer, 

there are 4 land use categories. That’s why the number of classes is set as “4”)  
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• After setting the number of classes, click on “Classify”.  

• Finally, click on “Apply” and “OK”. 

 

1 

2 

3 
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The land use layer will appear on the workspace as follows. 
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When utilizing the MOLUSCE plugin in QGIS, it's essential to ensure that all input layers have the same number of rows and columns, which ensures matching 

geometries. This requirement is critical for several reasons, 

• Matching geometries 

For successful processing in MOLUSCE, the geometries of input rasters must align. This alignment entails having consistent characteristics such as cell 

size, coordinate reference system (CRS), and spatial extent. 

• Why matching geometry matters 

During the rasterization process, where vector data (e.g., roads or land use polygons) is converted to raster format, values are assigned to raster cells 

based on the vector data. Matching geometries ensure that this assignment occurs accurately, with vector data aligning correctly with the raster grid. 

Consistent geometries also contribute to reliable analysis, as MOLUSCE relies on uniform input data for accurate land use change simulations. 

• Steps to ensure matching geometries 

To achieve matching geometries, consider resampling input rasters to a common cell size if variations exist. Additionally, ensure all layers share the same 

CRS and adjust the extent of the rasters to align properly. By following these steps, we can maintain consistent geometries, leading to accurate and 

reliable results when utilizing the MOLUSCE plugin for land use change simulations in QGIS. 

The rows and columns count of the layers we use here should be 1725 and 1430 respectively, and the cell size should be 0.00025. These values were 

determined based on the pre-processed dataset we obtained while performing this analysis. Similarly, if you are engaged in this type of project, you need to 

resample the layers prepared above to adjust the cell size and other parameters as desired. However, since those steps were not successful through the 

QGIS version 3.22.7 that we used until now, we hope to use QGIS version 2.18.15 to resample the layers. 

Starting with the step of converting the vector layer to a raster layer, the following is repeated through QGIS version 2.18.15. It shows how to equalize Rows 

and Columns count and resize cells. And all these can be done very smoothly by using the ArcMap software. Let's examine those steps next.  
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Rasterization with QGIS 2.18.15 

• Open the updated land use layer with QGIS 2.18.15 as follows.  

• For that, you can click on the “Layer” on the main toolbar and open the layer toolbar. Then, Add Layer > Add Vector Layer 
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• Now let's convert this vector layer to a raster layer. For that, open the Rasterize tool. 

Click on the “Raster” on the main toolbar > Conversion > Rasterize (Vector to Raster) 
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• Then the following window will open. First, select the vector layer as the Input file (shapefile) here.  

• Next, we have to select the Attribute field. As you may remember, this rasterization process is done based on the field we select here. And, this field 

should be numeric.  
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• As selected in QGIS version 3.22.7, select the "LU" field here as well.  
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• The selected field will be shown as follows.  

• Next, click on “Select” to browse a location for the saving results.  
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• Then, the following window will open on the screen. Select a suitable location as your preference and give a file name. 

• Click on “Save”.  
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• The following warning message will appear on the screen. According to that, you have to set up the output resolution as you need for the raster layer. 

• Click on “OK” to proceed to set up the resolution.  
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• Set up the values here as same as before.  

• Click on “OK” to run the tool.  
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• The rasterized layer will appear on the screen as follows. 
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• Right-click on the layer and open the layer properties as follows. 

• Under the general properties of the layer, now you can check the columns and rows values and the coordinate reference system.  

 

• Go to the style properties and set up the following settings as same as before in the QGIS 3.22.7. 



80 | P a g e  
 

• This will provide a clear color combination to easily identify the land use categories.  
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• The raster layer will appear on the screen with the new color combination as follows. 
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• In the next step, we have to set up the cell size. For that, search for the “resample” tool in the processing toolbox. 

• Select the newly rasterized layer as for the “Input raster layer” here.  
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• Next, we have to set up the region's extent.  

• For that, click on the icon that contains 3 dots, and click on “Use layer/canvas extent”.  
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• Then, the following window will appear on the screen. 

• Expand the list and select the layer that you want to use as the region extent for this raster layer. 

• This extent of the region will be used for the extent of the new raster layer during the resampling process.  

                       

• The extent will be shown as follows. 

• Next, enter the cell size that you want. After that, click on “Run” to proceed.  
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Rasterization with ArcMap 

ArcMap is a comprehensive Geographic Information System (GIS) software developed by Esri, widely used for mapping and spatial analysis. It is not open-

source software; rather, it is a commercial product that requires a license for use. Despite this, it is renowned for its robust features, ease of use, and extensive 

support and documentation. 

Converting a vector layer to a raster layer can indeed vary in complexity between different GIS software. ArcMap generally offers a more user-friendly experience 

for this process compared to QGIS, primarily due to its more streamlined and integrated toolset. ArcMap's interface and tools are designed to facilitate easier 

conversion and resampling with fewer steps and more intuitive options. 

 

On the other hand, QGIS, being an open-source platform, sometimes presents challenges with tool consistency and ease of use. While QGIS has made 

significant improvements over the years and offers robust functionality, some users may encounter issues such as tool compatibility, less intuitive workflows, 

and occasional bugs during conversion and resampling processes. QGIS's flexibility and extensive plugin ecosystem, including tools like MOLUSCE, provide 

powerful capabilities for advanced users who are familiar with its interface. Additionally, QGIS's open-source nature means that it is continually evolving, with a 

strong community contributing to its development and troubleshooting issues. 

While ArcMap might offer a more straightforward and user-friendly experience for converting vector layers to raster layers, QGIS remains a powerful alternative, 

especially for those who can navigate its more complex toolset. Since QGIS is an open-source software, here we tried to use it for the entire process. But for 

this, you can also use ArcMap software like this.  
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2.2 Preparation of the layers for spatial variables 

This part is the most important part of this analysis. Because the prediction of future land use change depends on these layers. In the area that we took as the 

sample study area, from 2005 to 2020, the reasons that affected the change in its land use should be considered here. Generally, some reasons mainly affect 

the rapid changes in land use of a particular area. 

• Warfare and Armed Conflict 

• Economic Crises and Institutional Overhaul 

• Population Growth and Urbanization 

• Technological Advancements and Infrastructure Development 

• Climate Change and Natural Disasters 

• Policy and Land Reforms 

• Technological Diffusion and Innovation 

Rapid changes in land use happen because of different reasons, both natural and man-made. One big reason is warfare and armed conflict. When there's 

fighting, it affects places where lots of people live, no matter what kind of land it is. The effects of war on land can be different and can last a long time. 

Another big reason is when there are economic problems or big changes in how things are run. When money gets tight or when there are big changes in how 

the government works, it can suddenly change how land is used. For example, it might lead to things like cutting down trees illegally or changing from growing 

crops for money to growing food to eat at home.  

Then there's population growth and cities getting bigger. More people need more land, so places where food is grown might get turned into cities. When new 

roads or buildings are built, it changes the land too. Climate change and disasters like floods or wildfires can mess up the land. All these things, plus rules about 

land and new technologies, like better ways to grow crops or use solar power, all play a big part in how land is used. 

In the case of Dambulla, during the period considered above, no special reason has affected the land use of the area. But with the development of the 

country during the considered period (infrastructure development related to transportation, housing, agriculture, etc.), the built-up area of this region has 

increased significantly; especially the Municipal Council area. Population growth and rapid urbanization must be another reason for this. 
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According to our collective studies of the Dambulla area, these were identified as factors that somehow influenced its land use change between 2005 and 2020. 

1. Environmentally sensitive areas 

2. Road density 

3. Euclidean distances between roads 

4. Euclidean distances to the nearest town centers 

5. Population density 

6. Access to services 

7. Accessibility 

8. Land use efficiency 

9. Building density 

Separate layers should be created for each of these factors, and their rows, columns, and geometries should be the same as the previously created land use 

layers. If there is any problem and it is not the same, then the mistakes should be corrected as mentioned before. Next, let's see how we can create raster 

layers for these spatial variables. There are 9 variables shown here, and how to prepare the required raster layers for the following spatial variables is presented 

in several separate books. 

• Land use efficiency (Refer to the book ) 

• Building density (Refer to the book) 

 

1. Environmentally sensitive areas 

Here we use the “environmentally sensitive areas” of the area which is considered as a spatial variable. Generally, environmentally sensitive areas are 

protected by the government. Also, no permission is given for construction in those areas. To create this layer, first, open the land use layer of the 

Dambulla area. 

1. Click on the “Layer” on the main toolbar and open the layer toolbar. 

2. Then, click on “Add Layer”. 
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3. Next, click on “Add Vector Layer”.   

 

 

 



89 | P a g e  
 

 

Now, the following window will appear on the screen and you can browse the vector file that you want to open.  
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After clicking on “Browse”, the following window will open. Then, go to the relevant folder and select the vector file. Usually, a shape file consists  of 6 other 

files. The file type you should choose to open here is the "AutoCAD Shape Source" file. As per the instructions, click on that layer, and after that click on 

“Open”. 
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Again, click on “Open” to add the layer to the workspace. 
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The land use layer will appear on the screen as follows. 
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Now, right-click on the layer and click on “Open Attribute Table”.  
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The Attribute Table of the layer will open as follows. Under the column “Mainuse”, we can see the land use of every plot of the Dambulla regional area.  
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Considering these land use categories related to the Dambulla area, we divided their environmental sensitivity into 3 classes. This classification is based on 
the potential impact each land use category may have on the environment, considering factors such as habitat disturbance, biodiversity loss, pollution, and 
conservation importance. 

Environmental Sensitivity of Greater Dambulla 

Low Environmental Sensitivity (1) Medium Environmental Sensitivity (2) High Environmental Sensitivity (3) 

   - Aviation 

   - Bank and Allied 

   - Commercial/Residential 

   - Commercial 

   - Dam 

   - Educational 

   - Grassland 

   - Health 

   - Home garden 

   - Industrial 

   - Institutional 

   - Open space 

   - Other plantation 

   - Other roads 

   - RDA road 

   - Railway 

   - Rock 

   - Socio-cultural places 

   - Sports and amusement 

   - Stores and warehouse 

   - Transportation 

   - Under-construction sites 

   - Utility 

   - Vacant buildings 

   - Unclassified areas 

   - Abandoned tank 

   - Agricultural land 

   - Coconut plantation 

   - Mixed crop 

   - Paddy fields 

   - Plantations (other than coconut) 

   - Religious place 

   - Tourism 

   - Vacant lands 

   - Archaeological places 

   - Catchment area 

   - Forest 

   - Marshy 

   - River 

   - Scrub 

   - Water bodies 

 

 

Table 5 -Categorization of the environmental sensitivity 
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Now we can check, how many land use categories are contained under the “Mainuse” column. For that, 

1. Click on the “Select by expression” tool. Then, the following window will open. 

2. Click on the “+” mark and expand the “Fields and Values”. Or you can double-click on the “Fields and Values” to expand it.  
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After that, double-click on “Mainuse” from the expanded list.  

 

 



98 | P a g e  
 

If you properly double-click on that, it will be shown in the expressions tab as follows.  

• Then, click on “all unique”. It is used to see the all uniques under the selected field. 

 

 



99 | P a g e  
 

According to the previous step, all the unique related to “Mainuse” will be shown as follows.  
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Now, we have to select land use categories under these 3 sensitivity classes, and we can give a value to each class and enter those values in the attribute 

table. According to these, we can use 1 for low sensitivity, 2 for medium sensitivity, and 3 for high sensitivity. 

• First, we should create a new field in the attribute table named “Env_Sens”.  

• Click on the pencil icon and turn on the “Toggle editing mode”.  
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Now the layer is in editable mode. Then, click on the icon for “New field” as follows.  
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After clicking on the “New field” icon, the following window will open. Enter the Name as “Env_Sens” and keep the other settings default. We can keep the 

length of the integer as 1, because there are only 3 classes that we are going to use in this.  
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Then the newly added field will be shown as follows.  
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Now, we have to add the values into this new field. For that, we should filter each sensitivity class by land uses from the attribute table.  

1. Open the “Select by the expression” as before mentioned way. 

2. Expand the “Fields and Values”. 

3. Double-click on “Mainuse”. 

4. Click on “all unique”. All the uniques under the “Mainuse” will be shown as follows. 

5. Then, you have to enter the following expression on the expression tab. For that, double-click on “Mainuse”, type “=”, and double-click on the relevant 

land use category according to the sensitivity classes. 

According to the above steps, first, select the land uses under the low sensitivity class. Once done entering a land use using this [“Mainuse” = ‘Aviation’], 

type “or” and follow the same steps to add other land use categories into the expression. The “or” operator is used here to create a logical condition that selects 

features based on multiple criteria. 

• So, add each land use continuously in this way, 

“Mainuse” = ‘Aviation’ or “Mainuse” = ‘Bank & Allied’ or “Mainuse” = ‘Commercial’ or “Mainuse” = ‘Educational’ 

After entering all land use categories into the expression using the above way, click on “Select”. 
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The selected data will be shown as follows.  

 



107 | P a g e  
 

In the next step, we have to add the value for the “Env_Sens” column. According to the above steps, we selected here the low-sensitive land use categories 

and we assigned the value “1” for this sensitive class. For that, click on the icon for “Open field calculator”.  
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The field calculator will open. Click on the “Update existing field” and make sure to display the “×” mark on that. Through this, an existing field in the attribute 

table is updated. 
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Now, we have to select the existing field that we want to update. For that, click on “OBJECTID” and expand it to the following fields. Then select “Env_Sens”.  
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After selecting the field, you can use the following expression to add “1” to the selected field at once. Then the sensitivity of all the low-sensitive land use 

categories we selected above will be updated as "1" on the attribute table.  

• Once done entering this expression, you can click on “OK” to proceed. This expression contains, 

Concat (“Name of the existing field”, ‘The value’) 

• You should correctly type this expression using single commas and double commas. If you do not enter this correctly, you will have an error message. 
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Now, the values are added to the attribute table.  
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You can deselect these all features using the below tool.  
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Following the same steps, select the medium environmentally sensitive land use categories as follows. 
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After selecting these, again open the field calculator and update the existing field as follows. Use the expression here as, Concat (“Env_Sens”, ’2’).  
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The updated field can be seen as follows. The "Env_Sens" field of the selected features shows the value "2". 
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All that remains is to select the highly environmentally sensitive land uses here. As an easy process for that, first, select low and medium environmentally 

sensitive land uses through "Select by the expression". For this, 

1. Double-click on “Fields and Values” and expand it. 

2. Again, double-click on “Env_Sens”. Then the “Env_Sens” will appear on the expression tab. 

3. Click on “all unique” and see the uniques under “Env_Sens”. 

4. Use the same expression to select low and medium environmentally sensitive land uses, “Env_Sens” = 1 or “Env_Sens” = 2 

5. Click on “Select”.  
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Now, all the low and medium environmentally sensitive land uses are selected on the screen. But we want to select the highly sensitive land uses here. For 

that, click on the “Invert selection” tool. 
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Then, the highly sensitive land uses will be automatically selected on the screen.  

 

 



119 | P a g e  
 

Now, we can follow the same process to enter the values for these features. Open the field calculator and update the existing field using the expression,  

Concat (“Env_Sens”, ’3’). 

 

After adding these values successfully, click on the pencil icon again and save the edits.  
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After saving the edits, open the layer properties and go to the “Style properties”. Next, click on “Simple fill”. Then expand the “Outline style” and select “No 

Pen”. After that, click on “Apply” and “OK”. Outlines of the vector layer will be removed from this process.  

 

Let’s categorize this vector layer. For that, click on “Single symbol” and expand it. Select “Categorized” from the expanded list. 



122 | P a g e  
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Next, expand the option “Column”, and select the field “Env_Sens”.  

 



124 | P a g e  
 

Click on “Classify”, then the classification will be displayed as follows. If you want to change the colors of each category, click on the color and select the color 

that you want. 
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Here is the classification according to the environmental sensitivity of the Dambulla region. 
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Next, we have to check the coordinate reference system and other requirements as the above land use layers. First, check the coordinate reference system as 

follows. If it is not match with the above land use layers, take the necessary actions to change it.  

 

And as before, this vector layer needs to be converted into a raster layer. After that, if the cell size, rows, and column values are not the same, the resampling 

process has to be done. In this way, you can prepare the layer for the environmental sensitivity of the Dambulla area. 
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2. Road Density 

Road density plays a pivotal role and can significantly influence land use patterns. Road density is a vital factor in land use simulation due to its profound 

influence on economic activity, urban expansion, environmental sustainability, and public service provision. By incorporating road density into land use models, 

planners, and policymakers can make more informed decisions that balance development needs with environmental and social considerations. This holistic 

approach ensures that land use planning supports sustainable and resilient urban and rural development. 

Initially, this book was developed using QGIS, an open-source GIS software. However, we have now transitioned to using ArcMap, which is not open source. 

The reason for this change is that QGIS cannot easily create road density layers, whereas ArcMap offers advanced tools that make this process straightforward 

and efficient. This adjustment ensures that the book remains practical and effective for users needing detailed road density analysis in their land use simulations. 

1. Opening ArcMap 

To create this layer, first, open Arc Map software. 
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Starting a New Map 

In the ArcMap startup dialog box, you can choose to open an existing map or start a new one. To create a new map, select "Blank Map" from “My Templates” 

and click "OK". This will open a blank map document where you can add and work with spatial data.  
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2. Adding a Shapefile 

To add a shapefile, first ensure that your shapefile (.shp) and its associated files (.shx, .dbf, etc.) are saved in an accessible directory on your computer. 

In ArcMap, go to the "File" menu and select "Add Data". Alternatively, you can click the "Add Data" button (represented by a plus sign icon) on the Standard 

toolbar. 

 

In the Add Data dialog box, navigate to the location of your shapefile. Select the shapefile you wish to add and click "Add". 
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The shapefile will now appear as a new layer in the Table of Contents on the left side of the ArcMap interface, and its data will be displayed on the map. For 

that, have added the road layer of Sri Lanka, which was downloaded from Open Street Map. 

 



132 | P a g e  
 

In the same way, the boundary (.shp) file created for the greater Dambulla area was imported. Now there are 2 layers in the workspace. 
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3. Run the Clip Tool. 

Then use the clip tool to select the road layer only for the relevant area. Go to the "Geoprocessing" menu at the top of the ArcMap interface and select 

"Clip". Alternatively, you can search for the Clip tool in the "Search" window or access it through "ArcToolbox" by navigating to,  

Analysis Tools > Extract > Clip. 
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Or select Geoprossessing > Clip 

 

I. In the Clip tool dialog box, set the following parameters. 
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II. Input Features: Select your road layer (the layer you want to clip). 

III. Clip Features: Select your boundary shapefile (the area you want to clip to). 

IV. Output Feature Class: Specify the location and name for the output clipped layer. Click the folder icon to navigate to the desired save location and 

provide a name for the new shapefile. 

After setting the parameters, click "OK" to run the Clip tool. The tool will process the data and create a new clipped road layer based on the boundary you 

provided.  
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Once the Clip tool has finished running, the new clipped road layer will be added to your map. Review the output to ensure that it accurately represents the 

roads within the specified boundary area.  
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4. Adding a previously prepared correct raster file for the setup of new factors. 

We need to ensure that the correct raster file is used because we follow the coordinate system, pixel size, and row and column configuration of this file. For 

this purpose, I have used a previously prepared 2005 Land use raster file. 
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The previously prepared land use layer for the year 2005 will appear on the screen as follows. 
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5. Ensure Consistent Coordinate Systems 

• First, make sure that all your layers (road layer, boundary shapefile, and raster file) have the same coordinate system. 

• Right-click each layer in the Table of Contents, select "Properties," then go to the "Source" tab to check the coordinate system. 

• After that, checked and noted the pixel size and row columns of the 2005 land use raster file.  
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141 | P a g e  
 

Upon examination, I observed discrepancies in the coordinate system of the clipped file. Consequently, I utilized the "Project" tool to rectify the coordinate 

system of the clipped file to match the desired one.  
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6. Project (.shp) file to the same coordinate system. 

If any layers have different coordinate systems, you need to project them to the same coordinate system. You can use the "Project" tool found under,  

Arc Toolbox > Data Management Tools > Projections and Transformations > Project 

 

Select the Clipped Road layer to the Input Dataset or feature class and select 2005 Land use raster layers’ coordinate system to coordinate system.  
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Once the project tool has finished running, check the coordinate system of the raster file.  
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7. Open the Line Density Tool. 

• Go to "ArcToolbox" and navigate to Spatial Analyst Tools > Density > Line Density.  

• If "Spatial Analyst" is not enabled, you need to activate it by going to Customize > Extensions and checking "Spatial Analyst". 
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Set Line Density Tool Parameters 

In the Line Density tool dialog box, set the following parameters: 

I. Input Polyline Features: Select your correct road layer. 

II. Output Raster: Specify the location and name for the output raster file.  
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Adjusting Pixel Size and Aligning with Existing Raster 

I. If the output raster needs to match an existing raster’s pixel size and alignment exactly, use the environment setting. Go to Environments. 

II. Then set up the workspace as the default workspace. 

III. Under "Raster Analysis," set the "Cell Size" to match your existing raster and set the " Mask" to match your existing raster. 

IV. Under "Processing Extent," set the "Extent" to your existing raster layer. 

Then change the environment setting as follows.  
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Then click “OK” to come back to the line density tool as follows. Again click on “OK” to run the tool.  
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Once the Line Density tool has finished running, the new road density raster will be added to your map. Review the output to ensure it accurately represents 

road density. 
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8. Check the coordinate system, pixel size, and rows & columns 

I. Right-click on the layer in the Table of Contents. 

II. Select "Properties". 

III. In the Layer Properties dialog box, go to the "Source" tab. 

The coordinate system information will be displayed in this tab. Ensure that it matches the desired coordinate system for your project.  
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9. Resample a Raster File. 

If you notice that the raster file does not have the correct pixel size or number of rows and columns, you can resample it.  (The first result obtained here is 

the same as the 2005 raster file values, so there is no need for a resample.) 

Open the Resample Tool 

Go to "ArcToolbox" and navigate to Data Management Tools > Raster > Raster Processing > Resample 
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Set Resample Tool Parameters 

In the Resample dialog box, set the following parameters: 

I. Input Raster: Select the raster file that needs resampling. 

II. Output Raster Dataset: Specify the location and name for the resampled raster file. 

III. Output Cell Size: Enter the desired cell size for the resampled raster. This should match the pixel size you need.  

              

Change Environment Settings 

Go to the “Environments". 

In the Environment Settings dialog box, set the following: 

I. If the output raster needs to match an existing raster’s pixel size and alignment exactly, use the environment setting. Go to Environments. 

II. Then set up the workspace as the default workspace. 

III. Under "Raster Analysis," set the "Cell Size" to match your existing raster and set the " Mask" to match your existing raster. 

IV. Under "Processing Extent," set the "Extent" to your existing raster layer. 
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• Cell Size: Set this to match the cell size of your resampled raster. 

• Mask: Optionally, you can set a mask to limit processing to a specific area.  

             

Run the Resample Tool 

Click "OK" to run the Resample tool. The tool will process the data and create a new raster with the specified cell size.  

 

After that, you can see the resampled layer as follows. 
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Again, check pixel size and rows columns. 

• Right-click on the layer in the Table of Contents. 
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• Select "Properties". 

• In the Layer Properties dialog box, go to the "Raster Information" tab.  

 

• If it is not the same this time, resample it again and then export this layer. 

10. Export Layer 

I. Right-click on the layer you want to export in the Table of Contents. 

II. Select "Data" and then "Export Data". 

III. In the Export Data dialog box, specify the location and file format for the exported layer. 
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Optionally, you can select the extent and coordinate system for the exported data. 

Click "OK" to export the layer with the specified settings.  
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Now that we have created and verified the road density raster layer, we can use it as a key input for the MOLUSCE (Module for Land Use Change Evaluation) 

land use prediction model. 
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3. Euclidean distances between roads 

Considering the Euclidean distance between roads as a factor in land use prediction is crucial for several reasons. Firstly, accessibility and connectivity are 

significantly impacted by the proximity to roads. Areas closer to roads generally have better access to transportation networks, making them more attractive for 

residential, commercial, and industrial developments. This improved accessibility often leads to the development of infrastructure and services, further 

enhancing the appeal of these areas for various land uses. 

Economic development is another key reason for considering Euclidean distance between roads. The distance to roads directly affects transportation costs for 

businesses, with shorter distances typically resulting in lower costs. This can influence business location decisions and promote economic activities in well-

connected areas.  

In terms of urban planning and expansion, the Euclidean distance to roads is an essential factor in land use allocation. Urban planners use road proximity to 

ensure that residential areas are close to necessary amenities and that commercial zones have adequate transportation access. This helps in predicting urban 

sprawl patterns, as areas near existing roads are more likely to be developed, shaping the overall growth and development of urban regions. 

To prepare the Euclidean distance for the road layer, follow the same steps as preparing the road density factor, up to clipping the road layer and ensuring the 

coordinate system is correct. 

1. Prepare the Road Layer 

• Download and Add Road Layer: Download the road layer for Sri Lanka from OpenStreetMap and add it to ArcMap. 

OpenStreetMap: https://www.openstreetmap.org/#map=7/7.879/80.767 

How to download GIS shapefile data from OSM: https://www.youtube.com/watch?v=iA2AF4f1_g4 

• Clip Road Layer: Use the Clip tool to restrict the road layer to the relevant area using a boundary shapefile. 

• Check Coordinate System: Verify the coordinate system of the clipped road layer with the previously prepared 2005 land use raster layer and ensure 

it matches your project's coordinate system. Use the "Project" tool if necessary to align the coordinate systems. 

https://www.openstreetmap.org/#map=7/7.879/80.767
https://www.youtube.com/watch?v=iA2AF4f1_g4
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2. Run the Euclidean Distance Tool 

Go to "ArcToolbox" and navigate to Spatial Analyst Tools > Distance > Euclidean Distance.  
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In the Euclidean Distance dialog box, set the following parameters: 

I. Input Raster or Feature Source Data: Select your clipped road layer. 

II. Output Distance Raster: Specify the location and name for the output distance raster file.  
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In the Environment Settings dialog box, make the following adjustments. 

I. Processing Extent: 

Set the "Extent" to match your 2005 land use raster. You can choose the raster layer from the dropdown list to ensure the extent matches exactly. 

II. Raster Analysis: 

Cell Size: Set the cell size to match the cell size of your 2005 land use raster. You can select the raster layer to automatically match the cell size. 

III. Mask:  

Optionally, you can set a mask to limit the processing to the area covered by your 2005 land use raster. 
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Click "OK" to run the tool. The tool will process the data and create a new Euclidean distance raster layer. 
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Once the Euclidean Distance tool has finished running, the new distance raster layer will be added to your workspace.  
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• After that, Right-click the new Euclidean distance raster layer in the Table of Contents. 

• Select "Properties" and go to the "Source" tab to confirm that the coordinate system, extent, cell size, and rows/columns match your 2005 land use raster. 

 

If these rows and columns are not equal, resample again and again like the previous road density and create your layer. 
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4. Euclidean distances to the nearest town centers 

Incorporating the "Euclidean distances to the nearest town centers" as a factor for land use prediction holds several merits. Firstly, proximity to town centers 

often correlates with patterns of human activity and development. Towns typically serve as hubs of commerce, services, and residential areas, exerting a 

significant influence on surrounding land use.  

The Euclidean distance metric provides a straightforward and intuitive measure of spatial relationship. It offers a clear representation of how far a given location 

is from the nearest town center, facilitating easy interpretation and integration into predictive models. Considering the distance to town centers acknowledges 

the influence of infrastructure and amenities associated with urban areas. 

Incorporating the Euclidean distances to the nearest town centers as a factor in MOLUSCE enhances its ability to predict land use changes by capturing the 

spatial dynamics of urbanization, accessibility to amenities, and the influence of infrastructure. By leveraging this metric, MOLUSCE can provide valuable 

insights into the evolving patterns of land use in diverse landscapes. 

1. Open QGIS. 

Open QGIS and create a new project.  
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2. Adding a basemap. 

Go to the menu and select Plugins > Manage and Install Plugins.  

 

• In the Plugin Manager, search for "QuickMapServices" and install it.  

• If it is already installed, it will show as "Reinstall". If not installed, it will show "Install". 
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• Once installed, go to Web > QuickMapServices > Settings. 

• In the "QuickMapServices Settings" dialog, click on "More Services" and then "Get contributed pack" (That’s for the latest update on maps) 

• Close the dialog and go to Web > QuickMapServices to choose a base map. 

• Select a base map provider from the list (e.g. OpenStreetMap, Google Maps) and click on it to add it to your project.  
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•  
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The base map will be added as a new layer in the Layers Panel. 
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Use the mouse cursor and zoom to your area. 
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3. Creating a Shapefile. 

In the menu, go to Layer > Create Layer > New Shapefile Layer. 
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Choose a directory to save the shapefile and give it a name.  
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In the "New Vector Layer" dialog box, specify the type of feature (point, line, or polygon), coordinate reference system (CRS), and attribute fields. Here I want 

to mark towns and therefore select points.  
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Then Select the coordinate system.  
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At this point, a column was added as a name to the attribute table.  

 

 



178 | P a g e  
 

Click "OK" to create the shapefile. 

Now the (.shp) file we created appears in the layers panel on the left.  
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To facilitate the identification of relevant areas, we have included the boundary shapefile for the Greater Dambulla area. This addition allows for easier and 

more accurate delineation of the specified region. 

4. Add the boundary Shapefile layer. 

• Go to Layer > Add Layer > Add Vector Layer. 

• Alternatively, you can click the Add Vector Layer button in the Data Source Manager toolbar. 

• Open the Data Source Manager 

• In the Data Source Manager dialog, click the ... button next to the Vector Dataset(s) field. 
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• Navigate to the location where your boundary shapefile is stored. 

• Select the Shapefile 

• Select the shapefile (.shp extension) you want to add.  
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Back in the Data Source Manager dialog, click “Add”.  

 

Your boundary shapefile will now be added to the Layers Panel. 
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Verify the Layer 

• Ensure the boundary layer appears in the Layers Panel. 

• You can right-click on the layer and select Zoom to Layer to view the full extent of your boundary. 

Adjust Layer Styling (Optional) 

• To change the appearance of the boundary, right-click on the layer and select Properties.  
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• In the Layer Properties dialog, go to the Symbology tab and adjust the style settings as needed. 

• Here I have adjusted the opacity. 
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5. Digitizing Features. 

• Select the layer you want to digitize in the Layers Panel. 

• Make sure the editing mode is enabled by clicking the "Toggle Editing" button in the Digitizing toolbar.  

 

Choose the appropriate digitizing tool from the Digitizing toolbar.  
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• Start digitizing by clicking on the map canvas to create points. 

• After clicking on a point, fill in attribute values for each feature using the attribute table. 
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Here are the added points according to the above way. 
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189 | P a g e  
 

Save your edits by clicking the "Save Edits" button in the Digitizing toolbar. Then click on “Save”. 
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You've created a shapefile, digitized features, and added a base map in QGIS.  

 

We will utilize ArcMap software for this task because it simplifies the process of calculating Euclidean distances to the nearest town centers. However, for other 

components of our analysis, such as point digitization, we will use QGIS. Using QGIS can't make an Euclidean distance map like the land use layer, so we will 

use ArcMap Software. 
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6. Open ArcMap 

Launch ArcMap on your computer and open a new or existing project.  

 

7. Add Shapefiles to the Map 

• Go to File > Add Data > Add Data 
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• Navigate to and select your shapefiles for the town centers and land use layers. (The 2005 land use raster layer is needed because the raster file that 

is being created now wants to follow same the pixel size of the land use layer) 

• Click “Add” to load them into your map. In this way, we import the shapefile previously prepared using QGIS into ArcMap.  
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8. Ensure Consistent Coordinate Systems 

• First, make sure that all your layers (Town centers layer and Land use layer) have the same coordinate system. 

• Right-click each layer in the Table of Contents, select "Properties," then go to the "Source" tab to check the coordinate system. 

                

After that, checked and noted the pixel size and rows columns of the 2005 Land use raster file.  

   Upon examination, I observed discrepancies in the coordinate system of the town center file.  
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9. Project (.shp) file to the same coordinate system 

• Consequently, I utilized the "Project" tool to rectify the coordinate system of the Town center's file to match the desired one. 

• If any layers have different coordinate systems, you need to project them to the same coordinate system. You can use the "Project" tool found under 

Data Management Tools > Projections and Transformations > Project on ArcToolBox.  
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Select the projected town centers layer to the Input Dataset or feature class and select 2005 Land use raster layers’ coordinate system to coordinate system.  
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Now you can see the projected town centers file. 
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Once the project tool has finished running, check the coordinate system of the raster file.  
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10. Open the Euclidean Distance Tool 

Go to ArcToolbox > Spatial Analyst Tools > Distance > Euclidean Distance.  

 

Configure the Euclidean Distance Tool 

I. Input raster or feature source data: Select the town center point layer. 

II. Output distance raster: Specify the location and name of the output raster file. 

III. Maximum distance (Optional): Set a maximum distance limit if needed. 

IV. Output cell size: Ensure it matches the cell size set in the Environment Settings. 
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Set the Environment Settings 

• Go to Environments. 

• In the Environment Settings dialog box, set the following: 

➢ Workspace: Set the current and scratch workspace. 

➢ Processing Extent: Set to the same as your land use layer. 

➢ Raster Analysis Settings: 

Cell Size: Set the cell size (pixel size) to match the resolution of your land use layer. 

Mask: Set the mask to your land use layer to ensure the output raster matches the area of interest. 

                  

By following these steps, you will create an Euclidean distance raster map that shows the distances from each cell to the nearest town center, with the correct 

pixel size and dimensions matching the land use layer. 
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5. Population Density 

Population density is a critical factor in land use prediction because it directly influences the demand for various types of land use. High population densities 

typically require more residential, commercial, and infrastructure development to support the needs of the population. This often leads to increased urbanization, 

with more land being allocated for housing, businesses, transportation networks, and public services. Consequently, urban planners and policymakers use 

population density data to forecast and plan for future land use needs, ensuring that adequate resources and spaces are available to accommodate growth. 

To create this layer, first, gather population or population data on a secondary data source. Since data is available for DSDs, we divide our study area for DSDs 

as well. 

01. Gather Data from the Department of Census website 

Website: http://www.statistics.gov.lk/#gsc.tab=0 

 

 

Go to Information>>District statistical handbook. 

 

 

 

 

 

 
Figure 6 -The interface of the website of the Department of 
Census and Statistics 

http://www.statistics.gov.lk/#gsc.tab=0
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Extract the Name of the District and select the year in which we are going to collect data. 

 

 

            

 

 

           Then it provides this information.  

Now we have collected the Population density data which we are going to map out. 
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Now that we have the data for the population density, we can create the population data layer.  
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02. Import population density data to QGIS 

Open QGIS and add a base map to it. 

 

Add a DSD (Divisional secretariat divisions) layer of Sri Lanka 
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After clicking on “Layer”, the following window will open. Then, go to the relevant folder and select the vector file. Usually, a shape file consists of 6 other files. 

The file type you should choose to open here is the "AutoCAD Shape Source" file. As per the instructions, click on that layer, and after that click on “Open”. ( 

For this you must have the relevant file.) 

Go to Layer > Add Layer > Add Vector Layer > Browse 
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03. Add a layer to the study area. 

Go to Layer > Add Layer > Add Vector Layer > Browse 

 

04. Run the Clip Tool. 
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Clip the DSD layer and the Boundary layer of the Greater Dambulla. 

Go to Vector > Geoprocessing Tools > Clip 
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I. Select the DSD Layer as the Input layer. 

II. Select the Boundary layer of the study area as the Overlay layer. 

 

 

 

 

 

 

 

 

 

III. After setting the parameters, click "Run" to run the Clip tool. The tool will process the data and create a new clipped layer based on the boundary you 

provided. 

This is the clipped output.  
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05. Create and update the Population density field 

Open the attribute table of the layer. For that, right-click on the layer > Open attribute table 

 

 

 

 

 

 

 

Add a new Field for Population Density. 

For that, click on the Toggle editing tool. 
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Add a new field as follows. Then you can see the menu like below you can enter the Field name and adjust the length of field characters. 

              

Now the new field will be added to the attribute table. Complete the Population Density column using collected data and save the changes. 
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06. Categorize according to the population Density. 

Right-click on the layer > Properties > Symbology > Graduated 
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Select Pop_Density as the value. 

 

 

 

 

 

 

 

Select the appropriate color ramp and number of classes > Classify > Apply > OK 
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This is the output vector layer for the population density of the Dambulla area. 

 

As mentioned in the first part of this document, this vector layer should be converted to a raster layer using QGIS or ArcMap. After that, if the cell size, row, and 

column values are not the same, the resampling process should be done.  
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6. Access to services 

Conducting an access to services analysis is essential for identifying gaps in service delivery, improving accessibility, and ensuring equity. This analysis helps 

in efficient resource allocation, strategic planning, and informed policy-making. It also enhances service quality through user feedback, ensures compliance and 

accountability, and fosters community engagement and empowerment. Also, it provides economic and social benefits, supports benchmarking and best 

practices, and establishes a framework for ongoing monitoring and evaluation. Overall, it ensures services effectively meet the needs of all community members, 

promoting social cohesion and stability. 

1. Open Arc GIS 
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New maps > Blank map > OK 

 

 

  



217 | P a g e  
 

2. Add Shapefiles to the Map 

i. Navigate and select POI data. 

How to download POI data:(Refer 15 min city book) 

Go to File > Add Data > Add Data > Select POI data > Add > OK 
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ii. Add land use layer (2005) to the ArcMap. (The 2005 land use raster layer is needed because the raster file that is being created now wants to follow 

the same pixel size of the land use layer. 

Go to File > Add Data > Add Data > Select Land use layer (2005) > Add > OK 
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3. Clip the POI data layer with the Land use layer. 

Search for the clip (Analysis) for this step. 
 

i. Input features - POI data layer. 

ii. Clip features - Layer of the boundary of the study area. 

iii. Give a path for the output. 

iv. Click “OK”  
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4. Run the Euclidean Distance tool. 

Open ArcToolBox.  
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Go to Arc Toolbox > Spatial Analyst Tools > Distance > Euclidean Distance  

 

 

i. Input the Clipped POI data layer as input raster here. 

  



222 | P a g e  
 

ii. Go to the environment setting and set the following. 

 Workspace: Set the current and scratch workspace. 

 Processing Extent: Set to the same as your land use layer. 

 Raster Analysis Settings: 

  Cell Size: Set the cell size (pixel size) to match the resolution of your land use layer. 

  Mask: Set the mask to your land use layer to ensure the output raster matches the area of interest.  
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This is the final output. 
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5. Review the raster layer 

Check whether the Coordinate system and Pixel size are the same for the land use layer by Layer properties. 

Right Click on the layer > Properties 

 

• Pixel size, row-column sizes, and coordinate systems are the same as the land use layer. So, no need to make any changes. 

• By following these steps, you can make the “Access to service” raster layer. 
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7. Accessibility 

Accessibility is a crucial spatial variable often used in land use change modeling, including in the MOLUSCE plugin. It refers to the ease with which different 

locations can be reached from a particular point, influencing land use patterns and development. High accessibility areas, such as those near roads, urban 

centers, or transportation hubs, are more likely to experience development and land use changes due to better connectivity and the movement of people and 

goods. 

In the context of land use modeling, accessibility can be quantified by measuring distances to key infrastructure elements like roads, highways, city centers, or 

public transportation stations. This variable helps predict how proximity to these elements affects land-use transitions, such as urban expansion or agricultural 

development. By incorporating accessibility as a spatial variable, models like MOLUSCE can more accurately simulate and forecast future land use changes, 

aiding in effective planning and resource management. Here are the basic steps for how to create a raster layer for accessibility using the Dambulla MC 

boundary. Although we explain how to create this layer using a different area extent here, all spatial variables and land use layers should have the same area 

extent. 

First, we have to prepare a sDNA layer using the current road network of the selected area. sDNA (Spatial Design Network Analysis) is a powerful tool used to 

analyze accessibility and connectivity within spatial networks, such as road systems. Also, it is a toolkit that integrates with GIS software to perform network 

analysis. It evaluates various metrics such as reach, betweenness, closeness, and straightness, which measure how easily different parts of a network can be 

accessed from any given point. These metrics help in understanding the flow of movement through a network, identifying key corridors, and predicting areas of 

potential development. This provides valuable insights into how the structure and connectivity of a road network influence land use patterns. 

To prepare an sDNA layer for accessibility analysis using a current road layer, start by obtaining a clean, topologically correct vector road network layer, typically 

in shapefile format. Ensure the sDNA toolkit is installed and configured in your GIS software (e.g., QGIS or ArcGIS). Then, preprocess the road layer to remove 

any gaps, overlaps, or disconnected segments, and simplify the network if necessary to streamline the analysis. 

Next, define the parameters for the sDNA analysis, such as the radius of analysis and specific metrics like betweenness and closeness. Run the sDNA tool on 

the road layer to calculate these accessibility metrics. The output will be a new layer containing these metrics for each road segment, which can be used as 

input in the MOLUSCE plugin to model the influence of accessibility on land use changes. We have to ensure this sDNA layer aligns correctly with other spatial 

data layers to validate the results. 
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Next, open the QGIS and input the boundary, and sDNA data to the interface.  
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Converting the line feature into points 

• First, we have to fix the geometries. For that, click on the processing toolbox and it will open the processing toolbox menu. 

•  

• Now type the “fix geometries” in its search bar. 
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• So, the fix geometries tool will appear under the menu, and double-click on it.  

• Then the fix geometries window will appear and select one of the SDNA layers from the drop-down menu of the input layer. (In this book we have used the 

sDNA_10km layer first) 
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• Click save to file and save your fixed sDNA layer into a folder.Then click on run. 

•  

1 

2 

3 
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• After running the process, you can get your fixed sDNA layer like below. 
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• Next, click on the vector tab. 

• Select geometry tools and click on centroids in there. 

• It will open the centroids window and select the fixed sDNA_10km layer from the drop-down menu in the input layer. 
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• Save the file in a relevant folder and click on run. (In there we saved the new centroid layer as point_10km) 

• After running the process, you can get the point layer for the sDNA dataset. 

  

1 

2 

3 
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• Following the same process in the above steps, you can fix geometries and then convert the line feature into points in the sDNA_1km layer.  

• So, after that, you can get the point layer for both sDNA_10km and sDNA_1km layers. Those point layers are used for the interpolation and creation of raster 

layers.  

•  
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Running the IDW interpolation tool 

• Click the processing toolbox in the ribbon 

• Type IDW interpolation in the search bar of the processing toolbox menu 

• The relevant tool will appear under the menu and double-click the IDW interpolation. 

• In the IDW interpolation window, select the relevant point layer as the vector layer. (In this book it is point_10km) 

•  

1 

2 

3 
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• Select the interpolation attribute as NQPDA10000 in the drop-down menu and click the plus mark below. 

• In the extent, select calculate from layer and then click on your relevant boundary. In this book, the extent is the Dambulla MC boundary. 

• Then save the interpolated layer to a file on your desktop and click on run to process. 

1 

2 

3 

4 

5 
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But most probably, we encountered an error in the process of interpolation with the QGIS as follows.  
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Optional Steps 

Because of the error encountered in the QGIS, we have done the interpolation process using Arc Map. For that, 

• First, input the point layers into the Arc Map interface. 

• Click on the search tab and it will appear the search menu of tools. 

• Then type the IDW interpolation in the search bar and click the search icon. 

• After searching for the tool, the list of tools will appear under the menu, and select the IDW interpolation (3D Analyst) tool. 

1 

2 

3 
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• It will open the IDW tool window and in there select your relevant point layer as the input point features. 

• Select NQPDA 10000 as the z-value field in the drop-down menu. 

• Keep output raster as default and click on environments. 

 

  



239 | P a g e  
 

• It will open the environment settings window and select the processing extent in there. 

• Select your relevant boundary layer as the extent. 

• Then click on the raster analysis drop-down menu to open it. 

• In raster analysis, select your boundary layer as the mask option and click ok. 

1 
2 

3 

4 

5 
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• After running the process, you can get the interpolated point layer of the 10km. 

 

• So, you have to do the same process mentioned above optional steps for your other point layer and interpolate it to obtain a raster dataset. (In this book we 

have to interpolate the point_1km layer following the same process we have done to the point_10km layer) 
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• Now you have obtained two raster datasets for accessibility. 
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Now you can export them to a folder for easy identification. For that right-click the interpolated layer.Go to the Data and click on export data. 
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• Export raster data window will appear and in there select a relevant folder to select your data by clicking the folder icon. 

• Then give the relevant name. In this book, we gave IDW_10km. 

• Select the format as TIFF format. 

• Then click on save. 

 

1 

2 
3 

4 
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• It will add a new raster layer to the interface and we can use it for further analysis in QGIS. 

 

• Do the same process mentioned in steps 12 to 17 to save the other interpolated layer as well. 
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• Now you have the two interpolated layers which can be added to the QGIS interface. 

 

Overlaying the two raster layers 

• Again, we are moving to the QGIS. Then we add the above two raster layers into the QGIS. 
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Now the interpolated data are added to the interface of QGIS. 

Overlaying the interpolated data using the raster calculator 

• Click on the processing toolbox icon. 
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• Type “raster calculator” in the processing toolbox’s search bar. 

• Once the relevant tool appears, double-click on the raster calculator tool to open it. 

 

1 

2 

3 
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• In the raster calculator window, type the equation in the expression tab. (The two interpolated layers equally contribute to and influence the accessibility 

level. By dividing 100% influence equally to two we can consider 0.5 as the weight factor for these two layers as they equally contribute to the accessibility 

level. So, we have to multiply each layer from 0.5 to get the accessibility level) 

• Then click on the three-dotted icon to select a reference layer. 
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• In the reference layer, select one of the layers and go back to the previous window. By accessing the reference layer, it will automatically assign the 

coordinate system, cell size, and output extent of the selected layer to the output layer. 

• So, there is no need to change the other parameters in the raster calculator and select a relevant folder to save the accessibility raster file. 

• Then click on run to overlay those two rasters. 
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So, you got the accessibility raster layer by overlaying the two interpolated layers. 
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Get the accessibility raster layer 

• Right-click on the accessibility layer and go to the properties. 

 

• Go to the symbology panel and select the render type as “singleband pseudocolor”.  

• Then select a relevant color ramp. 
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• Set “equal interval” as the mode. 

• We can categorize accessibility into 9 classes, so type “9” in the classes. 

• Then click on legend settings. 

• In the legend settings window tick off the use continuous legend and click “OK”. 

• After applying all parameters click “Apply” and “OK”. 
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• Now you can get the accessibility level raster layer. 
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CHAPTER 3: MOLUSCE PLUGIN TO MODEL THE FUTURE LAND USE CHANGE 

What is MOLUSCE? 

MOLUSCE (Modules for Land Use Change Simulations), is a robust QGIS plugin meticulously designed to analyze and predict the future land use change 

within specific regions. Employing a suite of algorithms encompassing Artificial Neural Networks (ANN), Logistic Regression (LR), Weight of Evidence (WoE), 

and the Markov Chain Ensemble (MCE) method, MOLUSCE excels in simulating and evaluating land use alterations over time. By ingesting raster data 

representing historical and current land use categories alongside pertinent explanatory variables, including socio-economic factors, the plugin seamlessly 

conducts model training to forecast future land use changes. With applications spanning urban planning for evaluating urban growth and development, forestry 

for predicting alterations in forest cover, and environmental impact assessment, MOLUSCE emerges as an indispensable tool for comprehensive land use 

analysis and informed decision-making. 

Modeling capabilities 

MOLUSCE boasts extensive modeling capabilities by incorporating diverse driving factors crucial for understanding land use dynamics, including proximity to 

roads, distance to urban centers, slope, environmentally sensitive areas, land use efficiency, population density, etc. By integrating these factors into its 

predictive models, MOLUSCE accurately forecasts future land use changes based on the provided data. Furthermore, the plugin offers validation tools such as 

kappa statistics to evaluate the performance of these predictive models, ensuring reliability and accuracy in assessing and predicting land use transformations 

over time. 

The maximum number of inputs for factors in the MOLUSCE plugin can vary depending on several factors, including the computational resources available and 

the complexity of the model being used. While there is no fixed maximum limit specified, MOLUSCE is designed to handle a wide range of input variables, 

allowing for a comprehensive analysis of land use changes. The actual maximum number of inputs may be determined by practical considerations such as 

available memory and processing power. 

Compatibility and Installation 
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MOLUSCE is compatible with QGIS, specifically versions 2.0 and above. QGIS 2.18 is usually used for this purpose. This is open-source software, and after 

downloading the setup, you can install QGIS 2.18 on your computer in a few simple steps. 

 

This version is compatible with Windows XP 64-bit, Vista 64-bit, Windows 7 64-bit, Windows 8 64-bit, Windows 10 64-bit, Windows 11 64-bit operating systems. 

While there are no strict formal requirements, it is recommended to have a minimum of 4 GB of RAM to ensure smooth operation, with additional RAM greatly 

enhancing processing speed, particularly for handling large datasets and complex analyses. While QGIS itself is not highly graphics-intensive, having a decent 

graphics card with OpenGL support can improve map rendering, 3D visualization, and overall system responsiveness, enhancing the user experience when 

utilizing MOLUSCE for comprehensive land use assessments and simulations. 
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1. After installing QGIS 2.18.15, we have to install the MOLUSCE plugin separately. For that, open the QGIS software. The interface looks as follows. 

You can see the main toolbars in the left upper corner of the interface.  
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2. Next, we have to install the MOLUSCE plugin. For that, open the Plugins toolbar from the left upper corner, and search for the MOLUSCE plugin as 

follows. Then the plugin will be shown. After that, click on “Install plugin” to install this plugin.  
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3. The installation process will be shown as follows. Once this process is complete, you can close the plugin's toolbar.  
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4. Now you can click on the Raster toolbar. It contains several tools and the MOLUSCE plugin as follows. Then again click on the “MOLUSCE”. Finally, 

the plugin and its related tools will be shown.  
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5. Click on the “MOLUSCE” and open the plugin now. The plugin will appear in the following way.  
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3.1 Modeling process with MOLUSCE 

All the land use layers and layers for the spatial variables should be imported to the QGIS. Then, you can see that the Layers Panel contains all these layers. 

Next, we can proceed with the MOLUSCE plugin. 
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Open the MOLUSCE plugin from the Raster toolbar. You can see all the layers in the project are shown in the “Inputs” tab here. The next step is to insert layers 

into the model as required. This plugin is very easy to use, and for this, it is important to set up the layers we use correctly. To predict the future land use 

change, the land use layers of two years should be used. The historical land use layer as the initial layer and the current land use layer as the final layer 

should be given here as inputs.  
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First, we have to add the initial layer. According to this project, the initial layer is the 2005 land use layer. Now click on “2005” to select the initial layer.  
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Then, click on the “Initial” button to add the selected layer to the model. 
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The initial layer was successfully added to the model. It is shown as follows. 
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With the same steps, you can add the Final layer to the model. In this scenario, our final layer is the 2020 land use layer. Click on “2020” and proceed.  
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In the next step, you have to add the spatial variables to the model. Here we consider the factors that affected the land use change in the period we consider 

above. That is how the future land use change is predicted through this plugin. The layers related to those factors should be added here under Spatial Variables. 

Following the same steps as before, you can add one by one layer to the model, or if you want to add these layers easily, select all spatial variables using the 

Ctrl key and click on “Add”.  

 

 



268 | P a g e  
 

 

Now, all the layers are successfully added to the model.  
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Next, the geometries of the layers need to be checked. For that, click on “Check geometry”. If the geometries of the all rasters are matched, the below message 

will be displayed. If the geometries of all the layers are not the same, the next step cannot be taken and an error message will be shown. Then the coordinate 

reference systems, rows and columns values, and cell sizes of all layers have to be rechecked.  
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Then, go to the “Evaluation correlation” tab. Here, Pearson's Correlation is used as the method. Now click on “Check” to proceed and you will get the matrix 

within a few seconds.  
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This matrix of correlation coefficients helps to understand how each spatial variable correlates with the actual changes in land use over time. By examining 

these correlations, we can identify which spatial factors have the strongest influence on land use dynamics and which may have a weaker or negligible impact. 

This information is crucial for refining the predictive models within MOLUSCE, as it allows us to prioritize the inclusion of spatial variables based on their 

significance in driving land use changes. This helps to improve the accuracy and effectiveness of the predictive models by better aligning them with the real-

world relationships between spatial variables and land use dynamics. 

In the context of Pearson's correlation coefficient, a value of 1 indicates a perfect positive linear relationship between the two variables being compared. This 

means that as one variable increases, the other variable also increases proportionally. In the evaluation correlation tab of the MOLUSCE plugin, if a correlation 

coefficient is close to 1, it suggests a strong positive correlation between the spatial variable and the observed land use changes. 

Values close to -1 or 1 indicate strong correlations, while values closer to 0 suggest weaker correlations. The sign of the correlation coefficient (+/-) indicates 

the direction of the relationship (positive or negative). Therefore, a correlation coefficient of 1 signifies a strong positive relationship, which is generally considered 

desirable in predictive modeling. 

 

When studying this matrix, we can see that the correlation between some variables takes negative values. That is, it can be recognized that those factors may 

have a weak or negligible effect on land use dynamics in the Dambulla area. 
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Next, go to the tab “Area Changes”. Set the units as “sq. km.” as follows. Then click on “Update tables”.  
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Then you will get this table and the matrix. The plugin calculates the area covered by each land use category in both time periods and then determines the 

changes that have occurred, such as expansion, contraction, or stability of each land use type. The purpose of this functionality is to provide us with quantitative 

insights into how land use has evolved or shifted over time within a specific region or area of interest. By quantifying the changes in land use, users can identify 

trends and patterns of land use dynamics. This information is invaluable for understanding and assessing the impacts of human activities or environmental 

factors, and informing land management and planning decisions. 

The numbers 1, 2, 3, and 4 in the class statistics table and the transition matrix indicate the four land use categories that we have selected. In this class statistics 

table under the "Area Changes" tab, the area change can be 0. This would indicate that the particular land use class has not experienced any change in the 

area between the initial and final periods being analyzed. The transition matrix shows how much area has transitioned from one land use class to another 

between the initial and final time periods. Each cell in the matrix represents the amount of area that has changed from one specific class to another. 
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Additionally, the "Area Changes" tab allows us to visualize these changes through a map, enhancing the interpretation and communication of the results. For 

that, click on “Create changes map” and select a location to save the map as your preference.  
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After clicking on “Save” in the previous step, the process will run as the below image. 
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After the saving, the area change map will appear on the workspace as follows. 

 

As the next step, go to the tab “Transition Potential Modeling” tab. Usually, we use here the Artificial Neural Network (Multi-layer Perceptron) as the 

method. Other parameters can be used as default values.  
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Then, click on “Train neural network”. 
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Now the model starts to train as follows. This will take a few minutes. This time depends on the speed of your internet connection and the processing speed of 

the computer used. 

 

Under this part, utilizing the Artificial Neural Network (ANN), specifically the Multi-layer Perceptron (MLP) method, involves a structured process. Firstly, we 

selected spatial variables influencing land use change. Then, raster data representing these variables for past and present periods are inputted. The plugin 



280 | P a g e  
 

trains the MLP model using this data, calibrating it to estimate the likelihood of transitions between different land cover types. Subsequently, MOLUSCE 

generates transition potential maps, delineating areas with heightened probabilities of specific land use changes.  

 

The neural network learning curve represents the performance of an artificial neural network (ANN) during training. It typically shows the training loss (also 

known as the error or cost) on the y-axis and the number of training iterations or epochs on the x-axis. The training loss measures how well the ANN is fitting 

the training data, and observing this curve helps determine if the model is overfitting or underfitting. As the number of iterations increases, the training loss 
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ideally decreases, indicating improved model performance. Keep in mind that specific implementations may vary, but this general trend holds for most neural 

network training processes. 

The validation of kappa involves assessing the accuracy and reliability of the predictive models generated by comparing the predicted land use changes with 

observed changes here. Kappa statistics measure the agreement between the predicted and observed land use transitions, providing a quantitative measure 

of model performance. Higher kappa values indicate better agreement between the predicted and observed land use changes, implying greater 

accuracy and reliability of the predictive models. 

"Delta overall accuracy" refers to the change in overall accuracy between two time periods. Overall accuracy is a measure of how accurately a predictive model 

or classification algorithm classifies land use categories compared to ground truth data. It represents the proportion of correctly classified pixels or areas out of 

the total number of pixels or areas. 

The "delta overall accuracy" specifically measures the difference in overall accuracy between two time periods, typically past and present. This metric provides 

insights into how the accuracy of land use change predictions has changed over time. A positive delta in overall accuracy indicates an improvement in 

accuracy, suggesting that the predictive model is better at capturing land use changes in the present period compared to the past. Conversely, a 

negative delta in overall accuracy indicates a decrease in accuracy, implying that the model's predictive performance has deteriorated over time. 
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Then, go to the tab “Cellular Automata Simulation” tab. In this step, we have to browse a suitable location to save the simulation results.  

 

Click on “Browse” and select a location as follows. Then, click on “Save”. 
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Then we have to set the number of simulation iterations. We used here the land use layers for the years 2005 and 2020. The gap is 15 years. So, one iteration 

equals 15 years here. If we set the number of iterations as “1” here, the prediction will be given for the year 2035. If it is set as “2”, the prediction will be given 

for the year 2050. 

After setting up the number of iterations as above, click on “Start”. Then the prediction will be started and it will be saved in the location that you selected before. 
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Once the prediction is done, that layer will appear on the workspace as follows. In this scenario, the number of iterations was set as “1”, so this prediction is for 

the year 2035. When you compare the 2005, 2020, and 2035 layers, you can see the land use change among those. 
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3.2 Past, present, and future scenarios of land use in the Dambulla region 
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4.PREPARATION OF MAPS   

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Use Suitable Colors & Symbols 

2. Show adjacent administration boundaries.  

3. Maximum utilization of map space 

4. Show the Graticule Network with appropriate grid size. 

5. Show the basic elements in the map.  

a. Transportation Networks   

b. Water Bodies 

6. Prepare a descriptive map.  

a. Label notable features. 

i.  Major Road Types 

ii.  Major Rivers  

iii. GN Boundaries 

iv.  If needed, show the location of the area in a different data frame. 

7. Check the units of the scale bar. 

8. Mention correct units at the legend. 

9. Check the text given in the legend. 

10. Mention the correct sources. 
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Figure 7 -Incorrect mapping 

 

 

Examples    

Maximum utilization of map space 

 

Check the units of the scale bar. 

 

Check the text given in the legend. 

 

Mention the correct sources. 
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AFTERWORD 

Effective land use planning requires more than just understanding current conditions—it demands foresight, analytical precision, and the ability to simulate 

change. This textbook provides a rigorous, methodologically sound framework for modeling future land use scenarios using the MOLUSCE plugin in QGIS, 

grounded in robust algorithms such as Artificial Neural Networks, Logistic Regression, and Weight of Evidence. 

Developed with both academic and professional audiences in mind, this book bridges theory and application, enabling users to engage confidently with complex 

spatial dynamics. As the pressures of urbanization, environmental change, and resource management intensify, tools like these become indispensable for 

anticipating growth, mitigating risks, and guiding sustainable development. 

We hope that this publication not only enhances technical proficiency but also fosters critical thinking and strategic planning in support of resilient, adaptive 

landscapes. May it serve as a lasting resource for those committed to shaping the future of land use through data-driven insight and informed decision-making 
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