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PREFACE 

This book serves as open educational material for both undergraduate and postgraduate degree 

programs, offering a detailed, step-by-step guide to Identifying Urban Boundaries and Urban 

Hierarchy based on Nighttime Light Image and Head/Tail Divisions. Designed to bridge the gap 

between theoretical knowledge and practical application, this guide is meticulously crafted to meet 

the needs of students, educators, and practitioners alike. 

Within the book, readers will find comprehensive instructions on using GIS software to analyze 

geospatial data and interpreting this data to Identify urban boundaries and urban hierarchy which 

leads to Identifying the dynamic nature of urbanizing processes. The book not only enhances 

learning in academic settings by providing real-world applications and case studies but also equips 

industry professionals with the skills necessary to conduct advanced spatial analysis and contribute 

meaningful insights in their fields. 
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Although there have been plenty of methods to delineate urban boundaries, most of the methods 

are contained within significant limitations. The most common limitation of Existing Urban Boundary 

Delineation Methods is failing to capture the actual functional and spatial boundaries of the cities. 

To mitigate limitations of existing boundary delineation methods, the topological approach which is 

based on the head/tail division rule is applied in this study to identify urban boundaries and urban 

hierarchy in Sri Lanka.  
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Figure 1 - Mapping Process 
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2. REQUIRED SOFTWARE 

QGIS Software  

 

 

 

 

.  

Version: QGIS 3.36 or later 

 

 

 

Installation: Available for Windows, macOS, Linux 

 

How to install QGIS on a Windows 10 compute 

https://www.youtube.com/watch?v=CLuSZB95ly0  

Video tutorial of QGIS for Absolute Beginners 

https://www.youtube.com/watch?v=kCnNWyl9qSE 

QGIS is a geographic information system software that is free and open source. For the mapping Purposes this study Used Q GIS. It supports viewing, editing, 

printing, and analysis of geospatial data in a range of data formats. 

https://www.youtube.com/watch?v=CLuSZB95ly0
https://www.youtube.com/watch?v=kCnNWyl9qSE
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3. HEAD/ TAIL DIVISION RULE FOR TOPOLOGICAL REPRESENTATION 

The Head/ Tail division rule is a data classification technique that is used in cartography and data visualization for heavy-tailed (heavily right-skewed) data 

distribution. The nature of heavy-tailed distributions is, that there are far more small belongings than large ones (Figure 1). For a better illustration and division 

of heavy-tailed data distribution, the head/ tail classification technique was developed in the year 2011 by Prof. Bin Jiang (Jiang, 2013). It's designed to determine 

the optimal breakpoints for dividing a dataset into classes or categories based on the natural clustering of data values. Therefore, the head/ tail division rule 

can be applied to both urban boundary delineation and urban hierarchy identification. 

The idea behind Head/Tail Breaks is to identify sub-classes in the data distribution where there are significant jumps or breaks, separating the "head" and the 

"tail" in a way that maximizes the differences between classes. The “head” contains the values higher than the mean value of the data distribution while the 

“tail” contains the values lower than the mean value of the data distribution. The head/ tail break application can be used recursively, as the breakings continue 

until the “head” section values no longer exhibit a heavy-tailed distribution or the head percentage becomes greater than 40%. (Jiang, 2013). The resulting 

breaks help create classes that highlight the natural grouping or clustering of data values while making it easier to visualize hierarchical patterns and differences 

in the dataset (Jiang, 2013). Figure 2 illustrates an example of the Head/ Tail break method application in a recursive manner.  

 

         
Figure 2 - Illustration of the Head/ Tail divisions (Jiang, 2013)              Figure 3 - Nature of heavy-tailed distribution  

Jiang, B. (2013). Head/tail breaks: A new classification scheme for data with a heavy-tailed distribution. The Professional Geographer, 65(3), 482-494. 



 

5 | P a g e  
 

4. STEPS 

4. 1 Data Preprocessing 

The dataset utilized for the analysis is Nighttime Light Imagery (NTL) data, which was collected from the Visible and Infrared Imaging Suite (VIIRS) from NASA 

Earth Data Explorer. The data was gathered for the year 2023. 

Step 1 

Download Nighttime Light Image  

Step 1.1: For this analysis, the nighttime light image was downloaded from the “Annual VNL V2” data collection from NASA Earth Data Explorer. Using the 
given link, access the “Annual VNL V2” webpage. https://eogdata.mines.edu/products/vnl/  

 

Figure 4 - Interface of the webpage (1) 

 

https://eogdata.mines.edu/products/vnl/
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Step 1.2: Click on the “Go to Download V2.2” button.  

 

Figure 5 - Interface of the webpage (2) 
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Step 1.3: In the directed webpage, select the year and download the nighttime light image. 

 

Figure 6 - Interface of the directed webpage (1) 

For this analysis, “VNL_npp_2023_global_vcmslcfg_v2_c202402081600.average_masked.dat.tif.gz” image (for the year 2023) was downloaded.  
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Figure 7 - Interface of the directed webpage (2)  
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Step 2 

Import downloaded Nighttime Light Image into QGIS map. 

Step 2.1: Open QGIS software and access the ‘Add Raster Layer’ dialog box on the left side of the interface.  

 

Figure 8 - The user interface of the QGIS software 
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Step 2.2: In the ‘Data Source Manager | Raster’ dialog box, give the file location path of the downloaded nighttime light image and add the image to the map. 

 

Figure 9 - Interface of the Data Source Manager | Raster dialog box 

 

1 

2 

3 

Figure 10 shows the imported Nighttime Light Image in the QGIS map.  
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Figure 10 - Imported raster layer in the map 
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Step 3 

 Extract nighttime light image into Sri Lankan (Case study boundary) extent 

To extract the raster image into the case study boundary (Sri Lankan extent), download the case study boundary shapefile and import the layer into the QGIS 
map. Then, extract nighttime light image into Sri Lankan extent as shown in the following steps.  

Step 3.1: Download the Sri Lankan boundary shapefile using the given link. https://data.humdata.org/dataset/cod-ab-lka?  

 

Figure 11 - Download the Sri Lankan boundary shapefile 

 

https://data.humdata.org/dataset/cod-ab-lka


 

13 | P a g e  
 

Step 3.2: Right click on the downloaded zip file and click on the “Extract Here” option. Then the extracted files can be seen in the same folder.  

     

Figure 12 - Extract the downloaded zip file      Figure 13 - Extracted files  
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Step 3.3: Click on the ‘Add Vector Layer’ dialog box on the left side of the interface. In the ‘Data Source Manager | Vector’ dialog box, give the file location path 

of the boundary shapefile and add the layer to the map.  

 

 

Figure 14 - Add Sri Lankan vector layer 

1 
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3 
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Figure 15 - Imported Sri Lankan layer 

 

Figure 15 shows the imported vector layer (Sri Lankan boundary) in the QGIS map.  
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Step 3.4: For ease of the identification, rename the layer. To do that, right click on the imported boundary layer and click on “Rename Layer”. 

 

Figure 16 - Rename the imported layer (1) 

Rename the layer as “SriLanka”. 

1 

2 
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Figure 17 - Rename the imported layer (2) 

3 
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To see the zoomed view of the imported boundary layer, right-click on the name of the layer and click on the “Zoom the Layer(s)” option.  

The zoomed view of the boundary layer can be seen in the map as in below figure 19.  

       

Figure 18 - Get zoomed view of a layer       Figure 19 - Zoomed view of the boundary layer 

   

 

1 

2 
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Step 3.5: To extract the Nighttime Light Image into the case study (Sri Lankan) extent, go to the “Raster” tab, click on “Extraction” and click on the “Clip Raster 

by Mask Layer”. Then select the Nighttime Light Image as the “Input layer” and the case study boundary layer as the “Mask layer” and, “Run” the dialog box.  

 

Figure 20 - Extract the Nighttime Light Image into the case study extent (1) 
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Figure 21 - Extract the Nighttime Light Image into the case study extent (2) 
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Figure 22 - Extracted Nighttime Light Image 

Figure 22 shows the extracted Nighttime Light Image in the QGIS map.  
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4.2 Urban Boundary Delineation 

In this analysis, urban boundary delineation is mainly based on the Head/Tail division technique. According to previous studies, urban boundaries can be 

generated based on the second head/tail classification when using Nighttime Light data as the input (Ren et al., 2024). 

Step 1:  

Identify the mean value of the pixel distribution. 

The head/tail divisions depend on the mean value of the data distribution. To do that, identify the mean value of the pixels by right-clicking on the Nighttime light 
layer and accessing “Layer Properties”. In the “Information” tab, the mean value of the data distribution can be found. Then copy the value. 

 
Figure 23 - Mean value identification 

Step 2 

First Head/Tail classification  
Ren, Z., Seipel, S., & Jiang, B. (2024). A topology-based approach to identifying urban centers in America using multi-source geospatial big data. Computers, Environment and Urban Systems, 107, 102045. 
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Step 2.1: In the “Raster” tab, click on the “Raster Calculator” option. 

 

Figure 24 - Raster calculator 
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In the raster calculator, select the nighttime light image raster band and complete the expression.  

 

 

 

(This is the first head/tail break classification in the study. Here, the values that are higher than the mean value of the data distribution are categorized as the 

“head” part while the values lower than the mean value of the data distribution are categorized as the “tail” part.) 

 

 

 

 

 

 

 

 

 

 

Nighttime Light band >= Mean value of the data distribution 
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Step 2.2: On the right side of the dialog box, fill in the output name, location, and output format, and then click on the “OK” button at the bottom of the dialog 

box. (To select the nighttime light image, double click on the layer name shown in the top left side of the Raster Calculator.)  

    

Figure 25 - First HT classification with the use of Raster Calculator 

Then, the selected pixels and the generated layer can be seen in the map. In this layer, value 1 (White colour) pixels are the “head” part of the Head/Tail 

divisions and value 2 (Black color) pixels are the “tail” part of the Head/Tail divisions.  

1 

2 

3 
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Figure 26 - Divided pixels – First HT classification 
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Step 3: 

Extract the selected ‘Head’ section of the image 

Step 3.1: To extract the ‘Head’ section of the image, first convert the raster image into to vector file by accessing the “Raster” tab, “Conversion” and “Polygonize 
(Raster to Vector)”.  

 

Figure 27 - Convert the raster image into to vector file (1) 
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Step 3.2: Then fill the dialog box as in the following figure and run the dialog box. 

  

Figure 28 - Convert the raster image into to vector file (2) 
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Figure 29 - Generated vector shapefile 

 

Figure 29 shows the generated vector shapefile. 
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In the attribute table of the vector layer, the values in the “DN” field are ‘1’ and ‘0’. Value ‘1’ means the “Head” section and value ‘0’ means the “Tail” section.  

 

Figure 30 - Attribute table of the vector layer 
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Step 3.3: To extract the ‘Head’ section from the layer, access the “Select features using an expression” option at the top of the attribute table. 

 

Figure 31 - Extract the ‘Head’ section from the layer (1) 

 



 

32 | P a g e  
 

Step 3.4: Type “DN = 1” and click on the “Select Features” box.  

 

Figure 32 - Extract the ‘Head’ section from the layer (2) 
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After, the selected areas can be seen on the map in yellow color. 

 

Figure 33 - Selected ‘Head’ section of the layer 
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Step 3.5: Right-click on the vector layer and click on “Export” → “Save Selected Features As…”. Then fill in the ‘Format’, ‘File name’, and file location and, 

export the layer as in Figure 35.  

 

Figure 34 - Extract the ‘Head’ section from the layer (3) 
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Figure 35 - Extract the ‘Head’ section from the layer (4) 
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Figure 36 - Exported ‘Head’ section shapefile 

Figure 36 shows the exported vector shapefile in the QGIS map. 
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Step 3.6: Click on “Raster” tab → “Extraction” → “Clip Raster by Mask Layer” and clip the nighttime light image by using the newly extracted ‘head section’ 

shapefile as the mask layer.  

 

Figure 37 - Clip the NTL image into ‘head section’ shapefile (1) 

1 
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Figure 38 - Clip the NTL image into ‘head section’ shapefile (2) 
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Figure 39 - Clip the NTL image into ‘head section’ shapefile (3) 

 

4 
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Figure 40 - Extracted nighttime light image 

 

Figure 40 shows the extracted nighttime light image (Selected ‘Head’ part from the first Head/Tail classification). 
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Step 4: 

Second Head/Tail classification  

For the second Head/Tail breaks application, repeat step 1 and step 2 (in the 4.2 Urban Boundary Delineation section). Then extract the urban boundaries by 
following the step 3 in the 4.2 Urban Boundary Delineation section. 

Second Head/Tail breaks application:  

 

Figure 41 - Get mean value for the second Head/Tail breaks application 
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Figure 42 - Raster calculator 
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Figure 43 - Second HT classification with the use of Raster Calculator 
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Figure 44 - Selected ‘Head’ section from the second Head/Tail classification (Raster image) 
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Identified ‘Head’ section/ Urban Boundaries extraction:  

 

Figure 45 - Convert the raster image into to vector file (1) 
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Figure 46 - Convert the raster image into to vector file (2) 
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Figure 47 - Generated vector file 
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Figure 48 - Extract ‘Head’ section of the second HT classification (1) 

1 
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Figure 49 - Extract ‘Head’ section of the second HT classification (2) 
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Figure 50 - Extract ‘Head’ section of the second HT classification (3) 
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Figure 51 - Identified urban boundaries in Sri Lanka 

Figure 51 shows the identified urban boundaries in Sri Lanka. 



 

52 | P a g e  
 

4.3 Urban Hierarchy Identification 

Step 1: 

Calculate the polygon areas of identified urban areas  

In this analysis, urban hierarchy is based on the polygon area of the urban clusters. For that, click on the “Open field calculator” in the attribute table of the 
generated urban area layer. Then fill the dialog box as shown in Figure 53 and click ‘OK’.  

 

Figure 52 - “Open field calculator” in the attribute table 
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Figure 53 - Calculate the polygon area of urban clusters  
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Then the calculated areas of urban clusters can be seen in the attribute table. 

 

Figure 54 - Calculated areas of urban clusters 
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Step 2: Convert polygons into points (Centroids) to interpret the hierarchy. 

Click on the “Vector” tab → “Geometry Tools” → “Centroids”. Then add the urban boundaries layer as the ‘Input layer’ and run the dialog box.  

 

Figure 55 - Convert polygons into points (1) 
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Figure 56 - Convert polygons into points (2)  
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Figure 57 - Generated centroids of the urban clusters 

 

Figure 57 shows the generated centroids of the urban clusters. 
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Step 3 

Get the mean value of the “Area” field. 

Step 3.1: To get the mean value of the “Area” field for the Head/Tail classification, click on the “Vector” tab → “Analysis Tools” → “Basic Statistics for Fields”.  

 

Figure 58 - “Basic Statistics for Fields” tab 
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Step 3.2: Copy the mean value of the “Area” field.  

    

Figure 59 - Mean value of the “Area” field 
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Step 4 

First Head/Tail classification – Select urban clusters which has area greater than the mean value. 

Access the Attribute table of the point layer and in the “Select/filter features using form” tab and make the following changes and click on “Select Features”. 

 
Figure 60 - First Head/Tail classification 

Then, right click on the points layer and access “Export” → “Save Selected Features As…” and export the selected points from the first head/tail classification.  
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Figure 61 - Save selected centroids layer of the first Head/Tail classification 

Then the selected centroids layer can be seen in the map. 
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Figure 62 - Selected centroids layer of the first Head/Tail classification 
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Step 5:  

Continue the Head/Tail classifications (Repeat Step 3 and Step 4) until the point count in the head part becomes 1.     

To get the urban hierarchy, the head/ tail brake application can be applied recursively until the number of centroids/ urban areas in the “head” section gets 1. 

Second Head/Tail classification.  

       

Figure 63 - Get basic statistics of the layer              Figure 64 - Mean area value of the centroids 
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Figure 65 - Second Head/Tail classification 
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Figure 66 - Export the selected points 
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Figure 67 - Selected centroids layer of the second Head/Tail classification 
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Third Head/Tail classification.   

    

Figure 68 - Get basic statistics of the layer               Figure 69 - Mean area value of the centroids 
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Figure 70 - Third Head/Tail classification 
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Figure71 - Export the selected points (1)              Figure 72 - Export the selected points (2) 
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Figure 73 - Selected centroids layer of the third Head/Tail classification 
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Step 6:  

Rename and re-colour layers as follow.  

Head part of the third head/tail classification – Level 1 (Red) 

Tail part of the third head/tail classification – Level 2 (Yellow) 

Tail part of the second head/tail classification – Level 3 (Green) 

Tail part of the first head/tail classification – Level 4 (Blue) 

Accordingly, following is the identified urban hierarchy map of Sri Lanka. 

 

Figure 74 - Identified urban hierarchy map of Sri Lanka 

Step 7:  
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To compare the generated urban hierarchy with the real ground, add OSM standard layer to the map. 

 

Figure 75 - Add base layer to the map 

 

 

Figure 76 shows the identified urban hierarchy in Sri Lanka. 
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Figure 76 - Identified urban hierarchy in Sri Lanka with the OSM layer 
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5. PREPARATION OF MAPS   

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Use Suitable Colors & Symbols 

2. Show adjacent administration boundaries.  

3. Maximum utilization of map space 

4. Show the Graticule Network with appropriate grid size. 

5. Show the basic elements in the map.  

a. Transportation Networks   

b. Water Bodies 

6. Prepare a descriptive map.  

a. Label notable features. 

i.  Major Road Types 

ii.  Major Rivers  

iii. GN Boundaries 

iv.  If needed, show the location of the area in a different data frame. 

7. Check the units of the scale bar. 

8. Mention correct units at the legend. 

9. Check the text given in the legend. 

10. Mention the correct sources. 
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Examples    

Maximum utilization of map space 

 

Check the units of the scale bar. 

 

Check the text given in the legend. 

 Mention the correct sources. 

 

Figure 77 - Incorrect formats of maps 
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AFTERWORD 

In a rapidly urbanizing world, understanding the structure and evolution of urban areas is essential for informed planning and policy-making. This 

guide offers a practical approach to identifying urban boundaries and hierarchies through innovative use of nighttime light imagery and Head/Tail 

Divisions. 

We hope this resource empowers students, researchers, and professionals to explore urbanization patterns with clarity and confidence. May it 

serve as a stepping stone toward data-driven urban analysis and more sustainable, well-informed development strategies. 
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